Login requires password (UNIX)

Module: Password Strength

This check reports agents that allow users to log in without entering a password. This is a serious breach of security. This check is available on AIX and Solaris systems only.

The following table lists the error messages for the check.

Table: Error messages for Login requires password

Message String ID and Category

Platform and Message Numeric ID

Message Title and Description

Additional Information

String ID: STKU_NO_PASSREQ

Category: ESM Error

UNIX (5345)

Title: Login does not require password

Description:The agent does not require user passwords upon login. This is a serious security breach. The listed accounts should require passwords upon login.

Severity: red-4

Correctable: false

Snapshot Updatable: false

Template Updatable: false

Information Field Format: [%s]

String ID: STKU_NOTSUPPORT_PASSREQ

Category: ESM Error

UNIX (5355)

Title: Login Requires Password not supported

Description:The agent does not support the Login Requires Password check.

Severity: green-0

Correctable: false

Snapshot Updatable: false

Template Updatable: false

Information Field Format: [%s]

String ID: STKU_PASSREQ_NOTFOUND

Category: ESM Error

UNIX (5385)

Title: Default password authentication parameter values not provided

Description:Default password authentication parameter values are not provided.

Severity: yellow-1

Correctable: false

Snapshot Updatable: false

Template Updatable: false

Information Field Format: [%s]

[an error occurred while processing this directive]