You can run all existing rules extensions that were created using Microsoft Visual Studio .NET 2005 Professional (whether they were compiled with .NET Framework 1.1 or .NET Framework 2.0) on Forefront Identity Manager Synchronization Service 2010 without recompiling your projects.

All new development and debugging for Forefront Identity Manager Synchronization Service 2010 rules extensions require Visual Studio 2008 or later. If you use Visual Studio 2005 Professional with your existing rules extensions, the extensions are converted to a Visual Studio 2008 Professional project and will be converted to .NET Framework 3.5.

For more information about upgrading Visual Studio projects, see How to: Upgrade Projects Created in earlier versions of Visual Studio in the MSDN Library.

See Also

[an error occurred while processing this directive]